Archive for October, 2008

WOD-PD 2008 | Web of Data Practitioners Days

On Wednesday and Thursday I attended the Web of Data Practitioners Days (WOD-PD 2008) at “Altes AKH” in Vienna. AFAIK it was the first event of such a kind, it was something in between academic presentations and hands-on sessions, everything about Semantic Web and its related technologies.

I liked this format of a workshop very much, especially the “hacking session” in the evening of the first day with its “lightning talks”, and of course the socializing in between the talks. I finally had the chance to talk to some guys I already knew from various blogs and publications, but never have met in real life.

The Semantic Web Company (an austrian company who is pushing the Semantic Web topic really hard forward) was represented by Jana Herwig and published a few blog posts summarizing the talks of the event:

The proceedings are online with almost all presentations and links to the web sites which were used for the hands-on sessions.

Oh yes, of course there are pictures online on Flickr tagged with wodpd2008.

Leave a comment »

Recent problems with launching Conzilla

I got several emails these days from people who were not able to launch Conzilla anymore. The reason was an exception (“java.net.MalformedURLException: no !/ in spec”) during start up.

I investigated the problem (which is caused by a regression bug of Sun’s most recent Java 5.0, i.e. 1.5.0_16) and tried to work around it, but came to the conclusion – as many other developers who tried to solve the very same problem – that it is best to wait for a fix from Sun.

The reason is that it would require too many changes in the code and even some major refactoring. Apart from that, even third-party libraries as e.g. log4j are affected. Conzilla is not the only application which has been broken, basically all applications making use of Java Web Start are affected.

Bugs have been reported to Sun:

http://bugs.sun.com/view_bug.do?bug_id=6746185
http://bugs.sun.com/view_bug.do?bug_id=6753651

Let’s hope that Sun fixes this bug very soon, until then my recommendation is: Do not use JRE/JDK 1.5.0_16, and if you happen to use it, downgrade to an earlier release, or upgrade to 6.0/1.6.

I will keep you informed regarding this issue.

Comments (1) »